C# Server Не понятная ошибка сервера

EvaCrystal

New member
Пользователь
Сообщения
7
Баллы
1
Здравствуйте, у меня вот такой вопрос, вроде бы настроила все файлики, но при запуске сервера вот такое выдает.

Снимок15.PNG

В файле conf.json. Стоят такие записи
JSON:
{
    "maxplayers" : 100,
    "name" : "RAGE:MP Unofficial server",
    "gamemode" : "freeroam",
    "stream-distance" : 500.0,
    "announce" : false,
    "csharp" : "enabled",
    "port": 22005
}
В файле settings.xml
XML:
<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <acl_enabled>true</acl_enabled>
  <log_console>true</log_console>
  <log_chat>true</log_chat>
    <resource src="gtarpmodes" />
</config>
В файле meta.xml ссылка на dll который получается при компилировании.
XML:
<meta>
  <info name="gtarpmodes" type="script" />
  <script scr="bin/Debug/netcoreapp3.1/gtarpmode.dll"/>
</meta>
Подскажите, где у меня ошибка?
P.S. И еще такой вопрос, какой версии подключать gtanetworkapi 0.3.7 или 1.1?
 

NozmaD

Администратор
Команда форума
Администратор
Сообщения
166
Баллы
208

EvaCrystal

New member
Пользователь
Сообщения
7
Баллы
1
Какой мод у вас используется?



Ежели думаете, значит 0.3.7
1.1 на этапе тестов только
Мод никакой еще не используется. Сама вот в этом разбираюсь. И на сколько я понимаю, знать разрабатывать мод под 1.1, не стоит? А как тогда подключить 0.37?
 

NozmaD

Администратор
Команда форума
Администратор
Сообщения
166
Баллы
208
@EvaCrystal, пришлите что идет при загрузке игрового мода ( [ServerEvent(Event.ResourceStart)] )
 

EvaCrystal

New member
Пользователь
Сообщения
7
Баллы
1
Пробовали по этому мануалу сделать?

Пожалуйста, Войдите или Зарегистрируйтесь, что бы увидеть скрытый контент.

Нет не пробовала, тут мануал старый на 2.0 версию, у меня же 3.1, к тому же сам сервер уже запускается все отлично. Но, какие дальше связанные с этим проблемы я тут уже спрашивала, так ни кто и не ответил. И лучше всего конечно, обновить мануал, на актуальную версию. А не годичной давности. Но, видимо это не кому делать. Или просто не знают как.
 

EvaCrystal

New member
Пользователь
Сообщения
7
Баллы
1
@EvaCrystal,

Пожалуйста, Войдите или Зарегистрируйтесь, что бы увидеть скрытый контент.

Это я смотрела. Спасибо, но мне это не поможет. Потому как там не показано, как подключаться бд MySQ. Потому что из тех гайдов которые я находила сама в инете ни один не подошел. Сам сервер у меня запускается. Но, если делать подключение к базе. То выдает ошибку в исключения и в базу ничего не записывает. Но, если сделать обычное консольное приложение, то в базу все записывается.
 

EvaCrystal

New member
Пользователь
Сообщения
7
Баллы
1
@EvaCrystal, пришлите что идет при загрузке игрового мода ( [ServerEvent(Event.ResourceStart)] )
C#:
[CODE=csharp]
using GTANetworkAPI;

namespace gtarpmodes
{
    public class ServerEvents : Script
    {
        [ServerEvent(Event.ResourceStart)]
        public void OnResourceStart()
        {
            NAPI.Util.ConsoleOutput("[Server] Hi, i am here on Server!");
        }
    }
}
 

Вложения

  • Снимок55.PNG
    Снимок55.PNG
    49.7 КБ · Просмотры: 1
Верх